.Net源码论坛 [ 繁体中文 ]

发新话题 回复该主题

关于sql2008r2 error26错误的解决办法 [复制链接]

楼主
最近在源码讨论上,我发现有很多新手对sql error26错误不太理解,相信这个帖子能帮助你解决你的问题。
在学习ASP.NET 过程用到新建数据集并远程连接sql server 2008 数据库,出现下面的错误:
    <--在与 SQL Server 建立连接时出现与网络相关的或特定于实例的错误。
    未找到或无法访问服务器。请验证实例名称是否正确并且 SQL Server 已配置为允许远程连接。
    (provider: SQL Network Interfaces, error: 26 - 定位指定的服务器/实例时出错)-->
   因为sql server 2008默认是不允许远程连接的,sa帐户也是默认禁用的,如果想要在本地用SSMS(SQL Server Management Studio Express)
   连接远程服务器上的SQL Server 2008,需要做两个部分的配置:
      1,SQL Server Management Studio Express(简写SSMS)
  2,SQL Server 配置管理器/SQL Server Configuration Manager(简写SSCM)
下面是具体的操作步骤:
(1:   打开SSMS,用windows身份连接数据库,登录后,右键选择“属性”
         左侧选择“安全性”,选中右侧的“SQL Server 和 Windows 身份验证模式”以启用混合登录模式
  
(2:选择“连接”,勾选“允许远程连接此服务器”,然后点“确定”

(3:展开“安全性”->“登录名”->“sa”,右键选择“属性”  ,然后左侧选择“常规”,右侧选择“SQL Server 身份验证”,并设置密码;选择“状态”,选中“启用”,点击“确定”

(4:右击数据库选择“方面”,将“RemoteAccessEnabled”属性设为“True”,点“确定”

(5:至此SSMS已设置完毕,先退出,再用sa登录,成功即表示sa帐户已经启用
     下面开始配置SSCM,打开SSCM:
                                        
(6:选中左侧的“SQL Server服务”,确保右侧的“SQL Server”以及“SQL Server Browser”正在运行

(7:右侧的TCP/IP:双击打开设置面板将其修改为“Enabled” ,
        选择“IP Addersses”选项卡,设置端口“1433”,
        将"Client Protocols"的"TCP/IP"也修改为“Enabled”

(8:配置完成,重新启动SQL Server 2008,如果是visual studio 2010 则是:
    
(9:此时应该可以使用了,但是还是要确认一下防火墙:打开防火墙设置。将SQLServr.exe(C:\Program Files\Microsoft SQL Server\MSSQL10.SQLEXPRESS\MSSQL\Binn\sqlservr.exe)添加到允许的列表中。



分类: 数据库
分享 转发
2014奋斗不止
TOP
沙发

不错,谢谢了
TOP
发新话题 回复该主题